5 thoughts on “ADPassMon updated to v2.20.9

  1. Thanks Peter,
    In quickly testing the application on 2 Macs does not show in the Menu bar though their is a process running in Activity Monitor. The first Mac is on 10.9.5 and has the managed preferences from our JSS and the LaunchAgent to keep alive, just incase that was the case i’ve just tried it on a 10.10.5 Mac with no managed prefs or LaunchAgent and i get the same behavior (also connected the VPN incase it was part of the new function you’d added)
    When i initially opened i double clicked and got the “can’t open un-identified developer message” so opened with right click >open.
    Here’s the console output:
    10/9/15 8:47:51.717 AM ADPassMon[17419] Running on OS 10.10.x
    10/9/15 8:47:51.724 AM ADPassMon[17419] *** -[ADPassMonAppDelegate applicationWillFinishLaunching:]: Can’t make missing value into type boolean. (error -1700)
    10/9/15 8:50:39.453 AM ADPassMon[17419] *** -[ADPassMonAppDelegate applicationWillTerminate:]: missing value doesn’t understand the “releaseStatusItem” message. (error -1708)
    10/9/15 8:52:54.877 AM ADPassMon[654] Running on OS 10.10.x
    10/9/15 8:52:54.883 AM ADPassMon[654] *** -[ADPassMonAppDelegate applicationWillFinishLaunching:]: Can’t make missing value into type boolean. (error -1700)

    • Thanks for the report. I’m pretty sure I know what’s happening. Please try setting the runIfLocal preference to false and relaunch ADPassMon. If that fixes it then I just need to add that into the defaults.

  2. Hi

    I just ran defaults write org.pmbuko.ADPassMon runIfLocal -bool false on both Macs and it’s written to the ~ plist ok.
    Tried a restart and opened the application and still no Menu item and console message is:

    10/9/15 10:47:18.612 AM ADPassMon[2974] Running on OS 10.10.x
    10/9/15 10:47:18.644 AM ADPassMon[2974] *** -[ADPassMonAppDelegate applicationWillFinishLaunching:]: 0 (error 1)
    10/9/15 10:47:45.926 AM ADPassMon[2974] *** -[ADPassMonAppDelegate applicationWillTerminate:]: missing value doesn’t understand the “releaseStatusItem” message. (error -1708).

    I swapped out the new version with V2.20.2 and that shows up in the Menu bar ok.

    Cheers,
    Andy

  3. Good morning Peter.

    I am testing v2.20.8 this morning on a 10.11 2012 iMac. I renamed v2.20.7, copied it to my archive for the older versions of ADPassMon, and copied v2.20.8 to my Utilities folder (where I like it to reside). Despite removing and then replacing the ADPassMon login item in Users & Groups, running the defaults write command you include (as sudo), and even after a couple reboots, nothing ever appears in the menu bar.

    When I remove v2.20.8 and replace it with v2.20.7 and reboot, as soon as I log in, there it is in the menu bar.

    Any idea what is happening (or not happening)?

    Thank you sir.

    ~Kris

Comments are closed.